This documentation is for development version 0.18.dev0.

mne.verbose

mne.verbose(function)[source]

Verbose decorator to allow functions to override log-level.

Parameters:
function : callable

Function to be decorated by setting the verbosity level.

Returns:
dec : callable

The decorated function

Notes

This decorator is used to set the verbose level during a function or method call, such as mne.compute_covariance(). The verbose keyword argument can be ‘DEBUG’, ‘INFO’, ‘WARNING’, ‘ERROR’, ‘CRITICAL’, True (an alias for ‘INFO’), or False (an alias for ‘WARNING’). To set the global verbosity level for all functions, use mne.set_log_level().

This function also serves as a docstring filler.

Examples

You can use the verbose argument to set the verbose level on the fly::
>>> import mne
>>> cov = mne.compute_raw_covariance(raw, verbose='WARNING')  # doctest: +SKIP
>>> cov = mne.compute_raw_covariance(raw, verbose='INFO')  # doctest: +SKIP
Using up to 49 segments
Number of samples used : 5880
[done]